Sunday, 23 February 2014

Lightroom Touchpad Scrollbar Fix

Lightroom and Synaptics touchpads (trackpads) don’t seem to play well together but climbbike1 at the Adobe forums posted a registry fix that worked for me.

I’m not sure what it does, but as stated the little scrollbar graphic that was popping up wherever my mouse was positioned no longer appears after applying this fix (a good thing as it seems to be related to the problem). I was having a similar problem with a few other apps I rarely use under Windows 8.1 and didn’t have the problem when using a proper mouse. Note the Control Panel –> Mouse applet/Synaptics tab reports that I’m running Synaptics Touchpad V7.2 on PS/2 and Device Manager states the Driver Version as (I just installed the latest driver when building the Windows 8.1 machine).

Here’s how to implement climbbike1’s fix.

Option 1 – edit the registry directly:

  1. With administrative rights on your Windows computer, run regedit.exe (either via Start –> Run or the search charm in Windows 8)
  2. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPEnh
  3. Right-click the SynTPEnh key and select New –> DWORD
  4. Name your new DWORD UseScrollCursor
  5. It’s value should be set to 0
  6. If the key already exists when you complete step 2, modify the value instead
  7. Restart the Synaptics processes (see below)

Option 2 – create and run a .reg file:

  1. Open notepad and save the blank file to your desktop as fixscroll.reg (or whatever you want to call it)
  2. Copy the italicised text below and paste it into your .reg file
  3. Double-click the file to run it (with administrative rights)
  4. Note I’m not sure if this will create the key if it doesn’t exist—follow the steps in option 1 to confirm it exists and is set correctly

Windows Registry Editor Version 5.00



You’ll need to restart a couple of Synaptics processes and can do this by either restarting your computer or following these steps:

  1. Open Task Manager
  2. Locate and end the Synaptics TouchPad Enhancements (SynTPEnh.exe) and Synaptics Pointing Device Helper (SynTPHelper.exe) processes
  3. Restart those same processes by running them from your startup folder or locating the executables and double-clicking them

Lightroom was running while I made these changes and the fix had instant results—no need to restart Lightroom or Windows.

If you found this post helpful, please support my advertisers.


  1. you rock! this worked like a charm! Thanks for posting.

  2. awesome. it works for me. thanks

  3. unfortunately doesn't work for me... running lightroom on a T430 with windows 8.1

    the driver version for "thinkpad ultranav driver" is (as shown in the "uninstall or change a program")

    1. same here..

    2. This comment has been removed by the author.

    3. Same here, I have win 8.1 on a t430s with the latest DriverVer=07/25/2014, and this did not fix the problem. I restarted my computer after the reg edit.

    4. Bummer, sucks to be you. I've only experienced this problem once on an HP laptop and note you're running a higher version of the Synaptics driver. Restarting should have the desired effect of restarting the necessary services but I'd double-check your registry change to ensure it's still there and correct (no typos and the key is the correct location).

  4. Option 1 and the restart worked for me. Thank You. This makes Lightroom so much more efficient! I have an HP and scroll abilities have not worked for Lightroom 4.3 from install. Thank You!


Spam comments will be deleted

Note: only a member of this blog may post a comment.